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1 Features and Known Issues in NIPO Fieldwork System 
1.11 

The NIPO Fieldwork System 1.11 is the latest edition of the NIPO Fieldwork System and 

contains new features implemented since versions 1.10 and 1.10 update. This document 

provides an overview of the new features. 

 

All fixes provided with the NIPO Fieldwork System 1.10 and 1.10 update are also 

implemented in NIPO Fieldwork System 1.11. 
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1.1 Most important (new) features of the NIPO Fieldwork System 1.11 

Quick overview: 

• NIPO CATI / Web Master: Multiple location support 

• NIPO FMS: Send E-mail invitations in waves 

• NIPO FMS: Warning when scheduling E-mail in the past 

• NIPO FMS: Confirmation message after Send again 

• NIPO FMS: Invitation E-mails and reminders no longer sent for inactive surveys 

• NIPO FMS: Send reminders based on interval after sent date, not scheduled date 

• NIPO FMS: Token-delimited export for sample tables 

• NIPO FMS: Allow filling or deleting sample table fields for currently selected field 

• NIPO FMS: GUI colors can now be changed 

• NIPO FMS: (Re)initialization of sample records: appointment time and call interval 

can now separately be cleared 

• NIPO FMS: Make or change appointments for more than one sample record at the 

time 

• NIPO FMS: Call interval fields can now be modified when editing a sample record 

• NIPO FMS: Survey files overview allows renaming files in the Exit room 

• NIPO FMS: Read-only fields in the Details screen can be copied to the clipboard 

• NIPO FMS: Improved sample table import of fields containing mixed data 

• NIPO FMS: Deletion of interviewer, survey and interviewer evaluation data no longer 

results in an occasional error 

• NIPO ODIN Engine: Improved interview progress estimation for NIPO CAWI and 

NIPO CAPI 

• NIPO ODIN Developer: Grid composer 

• NIPO ODIN Developer: Separate TemplateRelatedFiles folders for CAPI and CAWI 

• NIPO ODIN Developer: Nfield Code import and export 

• NIPO ODIN Developer: Export X-files to Nfield Code 

 

1.2 A Note on manual updates 

If you proceed with manual updates of the software by unzipping the release files into their 

respective program directories, be advised that you need to install the Microsoft Visual C++ 

2008 SP1 Redistributable Package (x86) for the NIPO ODIN Developer and the NIPO CATI / 

Web Master. Other software packages do not require this installation. 

 

http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-

3802B2AF5FC2&displaylang=en 

 

Administrator privileges are required to run this package. 
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1.2.1 Most important (new) features of the NIPO CATI / Web Master 3.09 

The following items have been changed as compared to the NIPO CATI / Web Master 3.05, 

as described in the NIPO Fieldwork System 1.10 Technical Reference Rev 20080509. 

1) Multi Location Support in the NIPO CATI / Web Manager 

Implemented in NIPO CATI / Web Master (Odmas32.EXE) 3.09 and higher. 

 

The NIPO CATI / Web Master now supports multiple locations. Supervisors and interviewers 

are able to access only the surveys assigned to their location; supervisors cannot access 

surveys belonging to other locations. This allows you to limit access to surveys as well as limit 

supervisor to view only to interviewers on their location.  

 

In the NIPO CATI / Web Manager, when a location is selected as currently active, only the 

surveys and interviewers for the active location are shown. When a survey is selected, only 

those interviewers working on the survey in the selected location are shown. However, more 

interviewers may be working on the same survey in a different location. When an interviewer 

workstation attempts to start a survey which does not belong to the same location, an error 

message is displayed and the survey cannot be started. 

 

To turn on the multi location function, the following registry entry (a string value) must be 

added on the NIPO CATI / Web Master: 

 

[HKEY_LOCAL_MACHINE\Software\NIPO\CATI Master] 

UseIdentity=1 

 

Adding this setting requires a restart of the NIPO CATI / Web Master service. 

 

There are four 'member' types to be grouped under locations.  

 

A) Users or Workstations running the NIPO CATI / Web Manager 

 

Users (based on MS Windows logon name) or workstations (based on computer name) 

running the NIPO CATI / Web Manager can be added as members of selected location. In the 

File > Configure >Master, User management window, the network logon name or the 

workstation names, depending on the registry setting PermissionsBasedOnUsers, can 

be added or removed from a location by double clicking them or use the left/right arrow 

buttons. New locations can be created by pressing the Add… button. 
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Note: 

• Alpha, numeric and underscore are allowed in location names. Other characters are 

not allowed (a speaker sound is produced at any attempt to type such characters). 

• The system is only aware of users or workstations that have at least once previously 

connected to the NIPO CATI / Web Master. 

• Locations cannot be deleted. 

• Members of the default location Unlimited can see all surveys and interviewers on all 

locations. 

• One user or workstation running the NIPO CATI / Web Manager can belong to 

multiple locations, and has access to a survey at any location if the survey was 

configured to at least one of his locations. However, interviewers are only visible for 

the currently selected location. 

Figure 1-1 | Grouping Users or Workstations on a selected location 
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B) Interviewer workstations 

 

Interviewer workstations can be members of a selected location. In Action > Rename 

Workstations windows of selected workstation, you can change the location of an interviewer 

workstation. 

 

 

 

Note: 

• A workstation can only be assigned to one location. 

• Workstations have no relation to interviewers – interviewers themselves may log on 

in any location. 

Figure 1-2 | Grouping a workstation to the selected location 
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C) Surveys 

 

Surveys can be added to be members of selected locations. In File > Configure > Survey… > 

Locations, a survey can be selected and its corresponding location can be selected. When 

Use defaults is selected, its multi-location setting is the same as the <<default>> survey. 

 

 

 

Note: 

A single survey may be run on multiple locations. 

Figure 1-3 | Grouping survey to selected locations 
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D) Web connections 

Web connections are in fact not part of a location, but they are still considered a kind of 

interviewer connection. Therefore, web connections must be assigned to a location. This 

location can be an existing call centre, or it can be a virtual (fake) location. 

 

Since all web connections are handled through the Web Demon, you can assign all web 

connections to a location by giving the Web Demon a location. This allows you to e.g. make 

web connections completely invisible to users, or to make web connections visible by 

assigning them to a special location and giving all call centre managers access to the 

location. By default, all call centre managers can always see the amount of web connections 

on surveys for which they have access. The web connections themselves however are 

invisible unless the user has unlimited access. 

 

To configure the location of the Web Demon, first start a web survey and assign it to the 

location in which you want web connections to appear. In the NIPO CATI Manager, make 

sure you have access to the location. Right-click on the Web Demon in the interviewer screen 

and select Rename workstation… Select the appropriate location from the drop-down list. 

 

Important note: 

When using locations, you must ensure that the web survey is assigned to the location where 

the Web Demon is assigned. Otherwise, web respondents will not be able to access the 

survey! One way to make sure this happens is by assigning the Default survey to the location 

of the Web Demon.
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1.2.2 Most important (new) features of NIPO FMS 1.11 

The following items have been changed as compared to the NIPO FMS 1.10, as described in 

the NIPO FMS 1.10 User’s Guide and the subsequent NFS 1.10 update document. 

1) Send E-mail invitations in waves 

When selecting a list of sample records to send an invitation, it is now possible to specify that 

the message is sent in waves rather than in one go. You determine the size of each wave in 

the number of E-mails. 

 

To set up a wave, make a selection of sample records to send the invitation to. Then right-

click on the grid and select Email > Send invitation… 

 

 

 

Check the box marked Schedule waves to specify that the current selection needs to be split 

into waves. At Wave size, specify the amount of E-mails that need to be sent per wave. At 

Interval, specify the interval between the waves in minutes. 

 

Click Send to finally send the E-mails. Note that the first wave is sent immediately or at the 

scheduled start date, as specified at the Start at time. 

Figure 1-4 | Send invitation E-mail in waves 
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When the option High priority is selected, this is only set for the first wave. 

 

Note that even if E-mails are sent in waves, they are still considered part of the single batch in 

which you sent them. The scheduled date is in fact the scheduled date of the entire batch, but 

the actual scheduled date may fall later depending on the selected interval and the wave in 

which the E-mail is planned! 

2) Warning when scheduling E-mail in the past 

When attempting to schedule E-mails on a date that has already passed, the NIPO FMS now 

issues a warning. You will be given the option to send the E-mails immediately. 

 

 

 

3) Confirmation message after Send again 

After choosing a selection of E-mails to be sent again, the NIPO FMS now displays a 

confirmation that the E-mails have been sent. 

4) Invitation E-mails and reminders no longer sent for inactive surveys 

NIPO FMS 1.10 erroneously sent invitation E-mails and reminders for inactive surveys. In 

NIPO FMS 1.11, these E-mails are no longer sent for inactive surveys. It is also not possible 

to schedule invitations for inactive surveys. 

5) Send reminders on interval based on sent date, not scheduled date 

NIPO FMS 1.11 now correctly sends reminders counting from the date the first mail was sent 

rather than the date it was scheduled. This is a small but sometimes relevant difference: due 

to other batches currently running, the NIPO FMS is not always capable of sending E-mails at 

the scheduled date. In such cases, E-mails are normally sent at the first available opportunity, 

but reminders are then often coming in a little early. 

6) Token-delimited export for sample tables 

You can now export sample tables as both fixed and delimited (CSV) text files. From the 

menu, select Actions > Export Sample table > Save as delimited ASCII file (CSV file)… and 

choose a filename. CSV files can be opened in for example Microsoft Excel. 

7) Allow filling or deleting sample table fields for currently selected field 

When selecting to fill or delete a field, the currently selected field is now taken as the default 

field to take action upon. 

Figure 1-5 | Scheduling mails in the past 
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8) GUI colors can now be changed 

It is now possible to change the GUI colors of the NIPO FMS. Select Configure > Options > 

Colors to open the color configuration tab. 

 

 

 

For the colors of grid items, an example grid is shown at the bottom right. 

 

To change the color of any of the items, click on the color drop-drown box. This will open a 

color selection box. 

Figure 1-6 | Configuring GUI colors 
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Select your color of choice using the color picker. Notice that the current color is displayed in 

the bottom left, and the current selection is displayed in the bottom right. 

 

In the color selection dialog, you can revert to the defaults for one or more colors. Click the 

checkbox for the item(s) which you wish to reset to the default, then click Set default colors for 

checked items to reset the default for your selection. Note that for colors that are already set 

to the default, the relevant check box is disabled. 

Figure 1-7 | Selecting a color 
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9) Clear appointment time and call interval independently on initialization 

When (re)initializing a number of sample records, you can now choose for both the 

appointment time and the call interval whether or not they need to be cleared. 

 

 

 

10) Make or change appointments for more than one sample record at the time 

You can now make or change appointments for more than one sample record at a time. In the 

sample table, make your selection, right-click the grid and select Make / Change 

appointment… from the dropdown list. The usual dialog for appointment changes appears. 

Any changes are applied to all records in your selection. 

Figure 1-8 |  Clearing appointment time / call interval at (re)initialization 



NIPO Fieldwork System 1.11 New Features and Known Issues | © NIPO Software Amsterdam | November 2009 | 13  

 

11) Call interval fields can now be modified when editing a sample record 

When right-clicking to edit a sample record, you can now also change the CallIntervalBegin 

and CallIntervalEnd values. These fields were previously disabled for editing in NIPO FMS 

1.10. 

 

Press the … button next to any of the appropriate fields.  A dialog is shown: 

 

 

 

To change any of the two times, select the appropriate checkbox. 

12) Survey files overview allows renaming files in the Exit room 

You can now rename files located in the Exit room. This may be useful if you need to export 

files to the Exit room that have not yet been removed, but should not be overwritten by files 

coming from the Working room. 

 

To rename files in the Working room, right-click on the file and select Rename… from the 

dropdown list. 

 

 

 

13) Read-only fields in the Details screen can be copied to the clipboard 

In the Interviewer or Survey details screen, you can now copy read-only fields such as the 

AuthenticationKey field, to the clipboard. To copy the field, right-click in the appropriate field 

and select Copy from the context menu. 

Figure 1-9 |  Changing the call interval begin and end values 

Figure 1-10 |  Renaming a file in the Exit room 
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14) Improved sample table import of fields containing mixed data 

In NIPO FMS 1.10, if you imported sample data into a field that contained both records with 

numerical values and records with text values, the import would fail as the MS SQL import 

expected numerical values based on the first content imported. A feature has been added to 

circumvent the error. To enable this feature, two registry values need to be added to the 

server running the NIPO FMS server. Note that these changes apply to the Microsoft Jet 

engine and can potentially slow down import.  

 

[HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\Excel] 

ImportMixedTypes=Text (string) 

TypeGuessRows=0 (dword) 

15) No more occasional error on deletion of Interviewer and Survey data 

When deleting Interviewer, Survey or Interviewer Evaluation data, an error would occasionally 

occur in NIPO FMS 1.10 and earlier. This happened because such data is copied to a backup 

table which did not always contain the fields of the originating table. The NIPO FMS now 

creates fields in the backup table to facilitate the procedure. 
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1.2.3 Known issues in NIPO FMS 1.11 

1) Documentation on search string 

The Search facility in the NIPO FMS was not properly documented. There was no apparent 

difference between a regular search and an Exact search: for example, a normal search for a 

string “Amsterdam” would not yield “Location Amsterdam” if such a record existed in the 

sample. This happens because the search facility only searches for entries starting with the 

specified string. For example, when searching for “Amsterdam”, the search could yield a 

record with “Amsterdam and around” if such a record existed. 

 

If you need your search to yield all records containing a particular word based on a partial 

match, you can use the wildcard %. For example, the search string “%Amsterdam” yields both 

“Location Amsterdam” and “Amsterdam and surroundings”. 

2) Search string should not be empty for exact searches on string fields 

When performing an Exact search on a field of type string or nvarchar, an empty search string 

produces an error. This error is non-fatal – simply change the search query or click All to 

display a new search result. 
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1.2.4 Most important (new) features of the NIPO ODIN Engine 5.15 

1) Improved interview progress estimation for NIPO CAWI and NIPO CAPI 

In the HTML templates of NIPO CAWI and NIPO CAPI it is possible to include a progress bar 

that gave a percentage of progression through the questionnaire. A number of issues have 

been resolved that improve the indicator's progress estimation: 

 

1. A bug has been removed in which a question too many was calculated for the total, 

causing the progress bar to end prematurely. 

2. All *DUMMY questions are now ignored for progress estimations. Note that null-

evaluating filter questions and questions without text are still counted – these can 

therefore be used to invisibly influence the progress bar. 

3. Progress is now correctly counted across *REPEAT and *GOSUB blocks. The 

progress bar no longer halts at such sections. 

 

Note: 

The progress bar can always jump forward disproportionally as it is subject to questionnaire 

routing and filtering. Also note that by design, the progress bar never actually reaches 100% 

(although rounding may cause it to occasionally hit 100% on very large questionnaires). The 

relocation page is considered to be the '100% page'. You may want to include a completed 

progress bar on this page.
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1.2.5 Most important (new) features of NIPO ODIN Developer 5.11 

The following items have been changed as compared to the NIPO ODIN Developer 5.08, as 

described in the NIPO Fieldwork System 1.10 Technical Reference Rev 20080509.  

1) Grid Composer 

Implemented in NIPO ODIN Developer 5.11 and higher. 

 

A user-friendly Grid Composer is now available to generate the scripting of grids and scales 

efficiently with adequate spacing. After entering the parameters in the Insert Grid Question 

screen, the script for the grid / scales will be inserted into the script in the Q-file. You can 

quickly create the script of grid / scales of *MULTI, *SCALE, *GRID, *NON, *CONTROL, 

VCONTROL commands to be further modified upon your needs.  

 

The following screen can be shown by right-clicking the coding area of NIPO ODIN developer 

and selecting Insert > Grid Question. 

 

 

 

 

Figure 1-11 | Configure the Grid Composer 
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Description Meaning 

Question Number The question number for this grid / scales 

Multiple answers 

allowed 

Check this to append *MULTI to all *SCALE commands or the 

*GRID command 

No answer allowed Check this to append  *NON to the *QUESTION command 

Statements on the x-

axis / y-axis 

The location of the statements will determine whether the 

composer will generate a *GRID or one or more *SCALE 

commands.  

- If the statements are on the x-axis a, grid will be generated 

and all *CONTROL/*VCONTROL options are available.  

- If the statements are on the y-axis one or more *SCALE 

commands are generated (the option to hide the column 

header will be greyed out as this combination is not possible). 

Under control of 

question 

Selecting and entering the question number to be dependent on 

will result in a *CONTROL statement being added after the 

*QUESTION statement. 

Include Selecting will result in a ‘W’ after the *CONTROL/*VCONTROL, 

else an ‘N’ will be generated. 

Hide column header if 

under control 

Only available when statements are on the x-axis to hide column 

headers if under control. Selecting it will result in *VCONTROL 

replacing *CONTROL.  

 

Add a new statement or scale item. 

 

Delete the currently selected item. 

 

Move the currently selected item up in the list. 

 

Move the currently selected item down in the list. 

Reload previous Reload the data of the last insert grid. 

Insert Insert the script to the Q-file. 

Cancel Cancel insertion of a grid. 

 

Table 1-1 | Explanation of Insert Grid Question screen 
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Parameters: 

 

 

Script generated with modification on question description: 

*TAB 20, 40, 60, 80, 100 

*QUESTION 2 *FORM *NON *VCONTROL Q1 W 

Why do you buy them? 

 apple orange banana pear 

1:Easy to buy *GRID L12 3.2 4.4 *MULTI 

 

Easy to store   

 

Inexpensive to buy  

 

Result: 

 

 

 

 

Example 1-1 | Using Grid Composer 
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Parameters: 

 

 

 

Script generated with modification on question description: 

*TAB 20, 46, 72, 100 

*QUESTION 2 *FORM *CONTROL Q1 W 

Why do you buy them? 

 easy to buy easy to store inexpensive to buy 

1:apple *SCALE L3 3 1 *MULTI 

2:orange *SCALE L3 3 1 *MULTI 

3:banana *SCALE L3 3 1 *MULTI 

4:pear *SCALE L3 3 1 *MULTI 

 

Result: 

 

 

Example 1-2 | Using Grid Composer 
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Note: 

• The grid composer works as a wizard: once inserted, the grid composer can no 

longer be used to modify the grid. Modifications need to be done directly on the script.  

• Validity of the question number and control question number in the grid composer are 

not checked against the questionnaire. Run a syntax check to check for errors. 

• The size of the field associated with *SCALE is computed based on standard scales 

that start from 1. If *SCALERANGE command with negative values is used, the 

computed field length may has to be manually adjusted.  

 

2) Separate TemplateRelatedFiles folders for CAPI and CAWI previews 

You can now set separate TemplateRelatedFiles folders for the CAPI and CAWI previews, 

rather than having to use the same folder for both. This is useful if scripting is required for 

both channels because there are small differences between CAPI and CAWI HTML 

rendering, and because you may wish to apply different templates and styling for the 

channels. 

 

3) Nfield Code import and export 

Nfield Code is the successor to the NIPO ODIN Coding Module. To support this application, 

Nfield Code imports and exports have been implemented in the NIPO ODIN Developer. 

 

To export a questionnaire and its open-ended answers to Nfield Code, select ODIN > Export 

> Nfield Code… from the menu. 

 

 

 

Select Use variable labels if present if you wish to use the labels defined by the *VAR and 

*LABEL commands. Select Include appointment notes to include appointment notes as a 

separate open-ended question. Select Includes notes to closed questions to include 

questions on which an open-ended answer was not available but forced. At Language, select 

the name of the original language in which the questionnaire was scripted. Note that the 

export always uses the code frame defined by the default language (the original script) – 

other languages cannot be exported. Click Save to save your currently selected settings. 

Click OK to finally create the Nfield Code import file. The file will be saved with the name of 

the survey followed with the extension NFC. 

 

 

Example 1-3 | Exporting to Nfield Code 



22 | NIPO Fieldwork System 1.11 New Features and Known Issues | © NIPO Amsterdam | November 2009 

Once the coding has finished and an NFC file has been exported from Nfield Code, this file 

can then be imported back into the questionnaire data by selecting ODIN > Import > Nfield 

Code… 

 

 

 

At Language, select which question and code frame translation, as set up in the Nfield Code 

project, you wish to use for the code frames in the resulting export. At Input file, select the 

NFC file you wish to read data from. At Output format, select the type of export you wish to 

make. Clicking OK brings you to the relevant export options for the selected output format. 

4) Export X-files to Nfield Code 

NIPO ODIN 4.08 coding files can be exported to Nfield Code. The NIPO ODIN Developer 

5.11 contains an export feature that allows you to create a Code Frame in Nfield Code format. 

To export an X-file as Code Frame file, click ODIN > Export > Export X file… from the menu. 

 

 

 

At X file, select the X-file to export to Nfield Code. At Destination, select a folder in which the 

Code Frames should be exported. Note that Nfield Code exports all Code Frames in the 

questionnaire. At Language, select the language for which the Code Frames should be 

imported in Nfield Code. 

Example 1-4 | Importing from Nfield Code 

Example 1-5 | Exporting an X-file to Nfield Code 
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Files are saved in the format 

 

[Surveyname]X_[SubquestionnaireNumber]_[Position]_[Length]{C[Code]}.nfcf 

 

The Position and Length parameters correspond to the question position and length as 

specified in the questionnaire. If the Code Frame is part of a semi-open ended question, 

Code specifies the code number on which the *OPEN command was used. 


